<!DOCTYPE html><html><head><link rel="apple-touch-icon" href="/pf/resources/icons/appleTouch/ohio/D-AppleTouch-152x152-2.png?d=95"/><link rel="icon" type="image/png" href="/pf/resources/icons/favicons/Ohio/dayton-favicon.ico?d=95"/><title>Vineyard Church in Beavercreek will give away 500 free turkey dinners for Christmas</title><meta name="description" content="Vineyard Church in Beavercreek will give away 500 turkey dinner kits for Christmas."/><link rel="canonical" href="https://www.dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="Vineyard Church in Beavercreek will give away 500 turkey dinner kits for Christmas."/><meta name="twitter:image" content="https://www.dayton.com/resizer/6K3PIH8-zphYuZcoXyBFM01nkcU=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg"/><meta name="twitter:site" content="@dayton"/><meta name="twitter:title" content="Beavercreek church to give away 500 turkey dinners the Saturday before Christmas"/><meta name="twitter:url" content="/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/"/><meta property="fb:app_id" content="1431445090472096"/><meta property="og:image" content="https://www.dayton.com/resizer/6K3PIH8-zphYuZcoXyBFM01nkcU=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:height" content="630"/><meta property="og:image:width" content="1200"/><meta property="og:title" content="Beavercreek church to give away 500 turkey dinners the Saturday before Christmas"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/"/><meta property="og:description" content="Vineyard Church in Beavercreek will give away 500 turkey dinner kits for Christmas."/><meta property="og:site_name" content="dayton"/><meta name="thumbnail" content="https://www.dayton.com/resizer/6K3PIH8-zphYuZcoXyBFM01nkcU=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg"/><meta name="language" content="English"/><meta property="article:opinion" content="false"/><meta name="story.meter" content="free"/><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","inLanguage":"en_US","mainEntityofPage":{"@type":"WebPage","@id":"https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/"},"publisher":{"@type":"Organization","name":"Dayton","logo":{"@type":"ImageObject","url":"https://cloudfront-us-east-1.images.arcpublishing.com/coxohio/YRHUB5MLSRHN3GFTFUEH36LH4M.png"}},"articleSection":"what to know","headline":"Beavercreek church to give away 500 turkey dinners the Saturday before Christmas","datePublished":"2020-12-11T16:54:51.558Z","dateModified":"2020-12-11T16:54:51.558Z","author":{"@type":"Organization","name":"Lisa Powell"},"image":{"@type":"ImageObject","url":"https://cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg"},"description":"Vineyard Church in Beavercreek will give away 500 turkey dinner kits for Christmas."}</script><link rel="amphtml" href="/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/?outputType=amp"/><link id="fusion-template-styles" rel="stylesheet" type="text/css" href="/pf/dist/components/combinations/default.css?d=95"/><script type="text/javascript">
        const initialDataObj = {
          "connextActive": "true",
          "pageData": {
            "pageName": "/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/",
            "pageURL": "https://www.dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/",
            "pageSiteSection": "/what-to-know",
            "pageMainSection": "/what-to-know",
            "pageCategory": "",
            "pageContentType": "Article",
            "pageTitle": "Vineyard Church in Beavercreek will give away 500 free turkey dinners for Christmas"
          },
          "siteData": {
            "siteID": "daytondotcom",
            "siteDomain": "dayton.com",
            "siteVersion": "responsive site",
            "siteFormat": "entertainment",
            "siteMetro": "oh: dayton",
            "siteMedium": "np",
            "siteType": "free",
            "siteCMS": "arc"
          },
          "contentData": {
            "contentTopics": "dcom_app,whattodo,whattoknow,verticals_lifestyles",
            "contentByline": "lisa powell",
            "contentOriginatingSite": "daytondotcom",
            "contentID": "B7VVT56WZZGANG3HG2CZR4BIWY",
            "contentVendor": "",
            "contentPublishDate": "20201211115908",
            "blogName": "",
            "galleryName": "",
            "contentPaywallStatus": "free"
          }
        };
        // we do a check just in case dataLayer has already been created
        if (window.dataLayer) {
          dataLayer.push(initialDataObj);
        } else {
          dataLayer = [initialDataObj];
        }
      </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P72HT8T');</script><script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script src="/pf/resources/scripts/prebid3.23.0.js?d=95"></script><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=95" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=95" defer=""></script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=95" defer=""></script><script type="text/javascript">window.ntvConfig = window.ntvConfig || {}; window.ntvConfig.keyValues = {"topics":"dcom_app,whattodo,whattoknow,verticals_lifestyles","uuid":"B7VVT56WZZGANG3HG2CZR4BIWY"};</script><script type="text/javascript" src="/pf/resources/scripts/nativo.js?d=95"></script><link rel="stylesheet" href="/pf/resources/dist/dayton/css/style.css?d=95"/><link rel="icon" type="image/x-icon" href="/pf/resources/icons/favicons/Ohio/dayton-favicon.ico?d=95"/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:pages" content="1431445090472096"/>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-a0f8de64-d75e-4e67-a72d-6b44e88ff95f","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="Q8952-D25UV-TUGGF-B5DRT-7NP9S",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"Q8952-D25UV-TUGGF-B5DRT-7NP9S",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax3yghax6tvmdq-f-a6e8d233d-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"1055649","ak.ai":parseInt("626554",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"973a88f","ak.r":40293,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":43678,"ak.gh":"23.222.12.108","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1607707399","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==iSFRzPLIMLmGgtA7XKqser+YgxMgUQjDWDkw2xCIBOKj+mqMQ336cL2YhJ8dPbG9mXOocKVzNZ4yC3c0pSMs+vJvvPEBNLwuH/NWu/q8SeQrYrxDnaIrOPvlYhUE8/2MQB6Dk2GcFzRPokMMV46kVfKrOyV75x0oBheIciCjuclYNJdWneF6rLuNIsTsL1MqyMdXS6LIOwNZrb8N+mI4ZKXikoUHZvILgiSrTttzAg1s15Z9dMDWVtiLPHw36OHttfEIdAchHoPz4qs+l8R08JYu0Gb6l+eDkiN5sx4THqSPOPx0kP8k/6+Lk0GTKE4eNpkRigXJw35mP0D2Pa4WUCzWzw6DljDRmqUhHID9SKQOdm6S5fy3tJK3+NVbRrgdhw/8h6nSA6Uyemm6hKB7iDSY+Og3vO4r0W9j3meF+v4=","ak.pv":"14","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src='https://www.googletagmanager.com/ns.html?id=GTM-P72HT8T' height='0' width='0' style='display:none;visibility:hidden'></iframe></noscript><div id="fusion-app"><div class="b-hidden"></div><div class="b-hidden"></div><div class="nav-breaking-news "><header class="c-nav"><div class="c-headerNav
        
        
        "><div class="b-flexRow b-flexCenter nav-logo
        "><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><div class="nav-mobile-logo "><a href="/"><img src="/pf/resources/logos/Dayton/logo-full.svg?d=95" class="logo dayton"/></a></div></div><div class="nav-wrapper "></div><nav class="
  
  
  "><div class="nav-menu-toggle"><div class="nav-close-button"></div></div><div class="nav-menu-header"><a href="/"><img src="/pf/resources/logos/Dayton/logo-mobile-hamburger.svg?d=95" class="nav-menu-logo dayton"/></a></div><ul class="nav-row"><li class="nav-mobile-footer"><div class="b-flexCenter b-flexRow"><div class="nav-social"><a href="https://www.facebook.com/daytondotcom" target="_blank" rel="noopener noreferrer"><img src="data:image/png;base64,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"/></a><a href="https://www.twitter.com/daytondotcom" target="_blank" rel="noopener noreferrer"><img src="data:image/png;base64,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"/></a></div></div><div class="nav-copyright b-flexRow b-flexCenter"><span style="padding-right:5px">© <!-- -->2020</span><a href="/">Dayton.com</a></div><div class="b-flexRow b-flexCenter nav-copyright-links"></div></li><li class="nav-weather-widget"></li><div class="nav-itemBottomBorder nav-sections"><li class="nav-items nav-itemText "><div class="activeSelection"></div><div class="nav-item-link bold"><a>What to Know</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-know/">What to Know</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-3"><li class="flyout-item"><a href="/what-to-know/" target="_self">All What to Know</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/tornado-recovery/tNzEAjgwWVdRFgQIecomCM/" target="_self">Dayton Strong: Tornado Recovery</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/oregon-district-shooting/" target="_self">Oregon District Mass Shooting</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Do</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-do/">What to Do</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/what-to-do/" target="_self">All What to Do</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/events/" target="_self">Events</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/breweries-bars/" target="_self">Breweries &amp; Bars</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/parks-recreation/" target="_self">Parks &amp; Rec</a></li><li class="flyout-item"><a href="/travel/worth-the-drive/TeSpLNabWxMiGdukqnFH5L/" target="_self">Travel</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/haunted-house-directory-2020/KNDLZHOUCJFCLL6JXOEO66YV2M/" target="_self">Haunted Houses</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Love</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-love/">What to Love</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-6"><li class="flyout-item"><a href="/what-to-love/" target="_self">All What to Love</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-bucket-list/" target="_self">Dayton Bucket List</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek/" target="_self">Daytonian of the Week</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-history/" target="_self">Dayton History</a></li><li class="flyout-item"><a href="/lifestyles/what-had-happened-was/5x2HBLiVbAUA2QAKCFdBhN/" target="_self">What Had Happened Was...</a></li><li class="flyout-item"><a href="/what-to-do/volunteer/volunteer-opportunities/" target="_self">Volunteer</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/best-of-dayton" target="_self">Best of Dayton</a></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/event-photo-galleries/" target="_self">Event Photos</a></li><li class="nav-items nav-itemText "><a href="https://myaccount.daytondailynews.com/dn/preference" target="_self">Newsletters</a></li><li class="nav-search"><form class="search-form"><button type="submit" class="c-search-icon"><img class="search-icon" src="data:image/svg+xml;base64,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"/></button></form></li></div><li class="nav-weather weather-icon weather-6" title="Mostly cloudy"></li><li class="nav-itemText nav-weather weather-text"><a href="/weather/">61<!-- -->°</a></li><div class="nav-mobile-login"><li class="nav-login nav-items "></li></div></ul></nav><div class="connext-subscribe  "></div><div class="stickyNav "><ul class="c-stickyNav-list dayton"><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><li class="stickyNav-item mobile-hidden"><a href="/"><img class="sticky-logo dayton" src="/pf/resources/logos/Dayton/logo-short.svg?d=95" alt="dayton logo"/></a></li><div class="stickyNav-social "><li class="stickyNav-item"><a href="https://www.facebook.com/share.php?u=https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/" class="sticky-nav-icon btn-facebook" target="__blank"></a></li><li class="stickyNav-item"><a href="https://twitter.com/intent/tweet?url=https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/&amp;text=Beavercreek church to give away 500 turkey dinners the Saturday before Christmas" class="sticky-nav-icon btn-twitter" target="__blank"></a></li><ul class="c-stickyNav-list dropdown-stickyNav "><li class="stickyNav-item arrow-icon desktop-hidden"><a href="#" class="sticky-nav-icon btn-arrow-down" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.pinterest.com/pin/create/button/?url=https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/&amp;media=https://www.dayton.com/resizer/6K3PIH8-zphYuZcoXyBFM01nkcU=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg&amp;description=Beavercreek church to give away 500 turkey dinners the Saturday before Christmas" class="sticky-nav-icon btn-pinterest" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.reddit.com/submit?url=https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/&amp;title=Beavercreek church to give away 500 turkey dinners the Saturday before Christmas" class="sticky-nav-icon btn-reddit" target="__blank"></a></li><li class="stickyNav-item"><a href="mailto:?Subject=Beavercreek church to give away 500 turkey dinners the Saturday before Christmas&amp;body=https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/" class="sticky-nav-icon btn-mail" target="__blank"></a></li></ul></div></ul><div class="b-flexRow c-stickyLogin"><div class="sticky-logo-homepage dayton hidden"><a href="/"><img src="/pf/resources/logos/Dayton/logo-short.svg?d=95" class="dayton" alt="dayton logo"/></a></div><div class="stickyNav-homepage hidden"><li class="nav-items nav-itemText "><div class="activeSelection"></div><div class="nav-item-link bold"><a>What to Know</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-know/">What to Know</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-3"><li class="flyout-item"><a href="/what-to-know/" target="_self">All What to Know</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/tornado-recovery/tNzEAjgwWVdRFgQIecomCM/" target="_self">Dayton Strong: Tornado Recovery</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/oregon-district-shooting/" target="_self">Oregon District Mass Shooting</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Do</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-do/">What to Do</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/what-to-do/" target="_self">All What to Do</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/events/" target="_self">Events</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/breweries-bars/" target="_self">Breweries &amp; Bars</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/parks-recreation/" target="_self">Parks &amp; Rec</a></li><li class="flyout-item"><a href="/travel/worth-the-drive/TeSpLNabWxMiGdukqnFH5L/" target="_self">Travel</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/haunted-house-directory-2020/KNDLZHOUCJFCLL6JXOEO66YV2M/" target="_self">Haunted Houses</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Love</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-love/">What to Love</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-6"><li class="flyout-item"><a href="/what-to-love/" target="_self">All What to Love</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-bucket-list/" target="_self">Dayton Bucket List</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek/" target="_self">Daytonian of the Week</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-history/" target="_self">Dayton History</a></li><li class="flyout-item"><a href="/lifestyles/what-had-happened-was/5x2HBLiVbAUA2QAKCFdBhN/" target="_self">What Had Happened Was...</a></li><li class="flyout-item"><a href="/what-to-do/volunteer/volunteer-opportunities/" target="_self">Volunteer</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/best-of-dayton" target="_self">Best of Dayton</a></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/event-photo-galleries/" target="_self">Event Photos</a></li><li class="nav-items nav-itemText "><a href="https://myaccount.daytondailynews.com/dn/preference" target="_self">Newsletters</a></li></div><li class="nav-login nav-items "></li></div></div><div class="c-comments "><div class="close">X</div><div class="fb-comments" data-href="https://dayton.com/what-to-know/beavercreek-church-to-give-away-500-turkey-dinners-the-saturday-before-christmas/B7VVT56WZZGANG3HG2CZR4BIWY/" data-width="100%" data-numposts="100"></div></div></div><div class="sticky-padding "></div></header></div><main class="c-articleContent"><header class="b-margin-bottom-d30-m20"><div class="c-header"><div class="article-headline-component b-margin-bottom-d30-m20 with-image"><div class="headline"><div class="headline-body"><h1 class="headline-text headline-text-long">Beavercreek church to give away 500 turkey dinners the Saturday before Christmas</h1></div></div><div class="c-image-component "><div class="image-component-image "><div class="lazyload-wrapper"><img src="/pf/resources/logos/Dayton/placeholder.svg?d=95" style="width:100%" data-placeholder="true" data-src="https://www.dayton.com/resizer/iG1dv9kK8ZdsBotRj_iWetHPvCE=/1066x600/cloudfront-us-east-1.images.arcpublishing.com/coxohio/Y3QKTUF7PKYWCBFQPTPCMI4PEM.jpg" alt="Vineyard Church in Beavercreek will give away 500 free turkey dinners for Christmas to those who register. FILE" class=""/></div><div class="c-caption " id="captionID-84387192" on="tap:captionID-84387192.toggleClass(class=&#x27;is-active&#x27;)" role="button" tabindex="0"><div class="photo-caption-btn"><div class="fill-line fill-line-long"></div><div class="fill-line"></div><div class="fill-line fill-line-long"></div><div class="fill-line"></div><div class="fill-line fill-line-long"></div></div><div class="photo-caption"><div class="photo-caption-text">Vineyard Church in Beavercreek will give away 500 free turkey dinners for Christmas to those who register. FILE</div><p class="photo-credit-text"></p></div></div></div><p class="photo-credit-text"></p></div></div></div><div style="display:flex;justify-content:center;flex-wrap:wrap" class="c-label-wrapper b-pageContainer b-margin-bottom-d15-m10"><a class="section-label section-label-link" href="/what-to-know/">What to Know</a><span class="article-timestamp"> | 28 minutes ago</span></div><div class="b-flexRow b-flexCenter b-pageContainer"><div class="byline b-margin-bottom-d40-m20"><span>By <!-- -->Lisa Powell</span></div></div><div class="b-flexRow b-flexCenter b-margin-bottom-d15-m10 b-pageContainer"><div class="subheadline-content"><span>Recipients must register in advance to receive the free meal kits</span></div></div></header><article><div class="c-hp01-mp01"></div><div class="c-articleBodyContainer is-safari"><div class="free-story-messaging connext-free-messaging b-margin-bottom-d30-m20"></div><div class="c-section
          full-width b-clear-both
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">Vineyard Church in Beavercreek is giving away 500 turkey dinners for Christmas.</p></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">The meal kits will contain sweet potatoes, green beans, potatoes, stuffing and dinner rolls to accompany a 20-pound turkey, all ready to be assembled and cooked at home.</p><section class="borders b-margin-bottom-d40-m20"><span class="prefix">Explore</span><a class="link" href="https://www.dayton.com/what-to-do/santas-gone-virtual-and-now-he-wants-letters-from-dayton-kids/NQG35RB6LREDNE7BGIYADOPTPU/" target="_self">Santa’s gone virtual, and now he wants letters from Dayton kids</a></section><p class="story-text b-margin-bottom-d40-m20">“It’s our way of helping people this Christmas,” said Scott Sliver, senior associate pastor at the Beavercreek church. “During this time, it’s important for people to know churches are still in business.”</p></div></div><div class="story-nativo_placeholder--moap b-clear-both"></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">Recipients must register in advance to receive the dinner — one per household — by calling 937-427-1912 or signing up online at <a href="https://urldefense.com/v3/__http:/www.daytonvineyard.com/dinner__;!!JZyed81S!3E_6q3UnwRf3CrxDhl-YiCWvGDrXSe6WjJPmMEya6unj6zLQ4p9UVWnisabdQcZrOA$">www.daytonvineyard.com/dinner</a>.</p><section class="borders b-margin-bottom-d40-m20"><span class="prefix">Explore</span><a class="link" href="https://www.dayton.com/what-to-do/heres-where-you-can-find-beautiful-holiday-light-displays-without-leaving-your-car/ZJV576FZRBBUHB5SHDJ2AXPIUQ/" target="_self">DAZZLING: Here’s where you can find holiday light displays without leaving your car or driving far</a></section><p class="story-text b-margin-bottom-d40-m20">Drive-through pickup will be available between noon and 2 p.m.  on Saturday, Dec. 19 at Vineyard Church, 4051 Indian Ripple Road in Beavercreek.</p></div></div><div class="c-section"><div class="story-interscroller__placeholder full-width c-clear-both c-contentElements"></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-subscription__placeholder subscription-promo b-margin-bottom-d40-m20"></p><p class="story-text b-margin-bottom-d40-m20">“This year more than ever, everything is heightened, people’s anxiety, their stress. They’re worried about so many things,” Sliver said. “This is one less thing to worry about. They can take Christmas dinner off their list.”</p><p class="story-text b-margin-bottom-d40-m20">For more information, contact Sliver by email at <a href="mailto:scott@dvc.life">scott@dvc.life</a> or by phone at 937-520-1561.</p><p class="c-connext hyperlocal_promo b-margin-bottom-d40-m20"></p><p class="c-connext eos-msg__nolog-or-nosub b-margin-bottom-d40-m20"></p></div></div><div class="c-section full-width b-clear-both"><div class="c-relatedList b-margin-bottom-d40-m20"><h1 class="title">In Other News</h1><div class="c-homeListContainer two-columns left-photo-display-class"></div></div></div><div class="taboola-split"><div class="story-nativo_placeholder--boap"></div></div></div></article></main><footer class="c-footer b-clear-both"><div class="logo-row"><div class="col"><a href="/"><img class="footer-logo dayton" src="/pf/resources/logos/Dayton/logo-full.svg?d=95" alt="logo"/></a></div><div class="col"><a href="https://myaccount.daytondailynews.com/dn/preference/" class="newsletter-signup"><p>Sign up for our newsletters</p><img src="data:image/svg+xml;base64,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" alt=""/></a></div></div><ul class="menu-row"><li class="menu "><div class="menu-header">What to Know<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://www.dayton.com/what-to-know/" target="">Latest Headlines</a></li><li class="menu-body-links"><a href="https://membercenter.journal-news.com/newsletters" target="">Sign up for Newsletters</a></li><li class="menu-body-links"><a href="https://www.dayton.com/contact-us/" target="">Contact Us</a></li></ul></li><li class="menu "><div class="menu-header">What to Do<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://www.dayton.com/what-to-do/events" target="">Events</a></li><li class="menu-body-links"><a href="https://www.dayton.com/what-to-do/dining" target="">Restaurants</a></li></ul></li><li class="menu "><div class="menu-header">What to Love<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="/best-of-dayton" target="">Best of Dayton</a></li><li class="menu-body-links"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek" target="">Daytonian of the Week</a></li></ul></li><li class="menu "><div class="menu-header">Event Calendar<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://dayton-community.pointslocal.com/community/authenticate" target="">Submit an Event</a></li><li class="menu-body-links"><a href="https://www.daytondailynews.com/local/visitor-agreement/OHHOKFZZZZBJBBU7LY4IY7TW6Q/" target="">Visitor Agreement</a></li></ul></li><li class="menu social-media"><span class="header-menu">Follow</span><ul class="social-media-icons"><li><a href="https://www.facebook.com/daytondotcom"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MCIgaGVpZ2h0PSI0MCIgdmlld0JveD0iMCAwIDQwIDQwIj4KICAgIDxwYXRoIGZpbGw9IiMyRTgxQjciIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTM0LjU5MiAwSDUuMzg3QTUuMzg3IDUuMzg3IDAgMCAwIDAgNS4zODd2MjkuMjA1YTUuMzg3IDUuMzg3IDAgMCAwIDUuMzg3IDUuMzg3aDE0LjQwNGwuMDI0LTE0LjI4NmgtMy43MTFhLjg3Ni44NzYgMCAwIDEtLjg3Ni0uODczbC0uMDE4LTQuNjA1YS44NzYuODc2IDAgMCAxIC44NzYtLjg3OWgzLjcwNXYtNC40NWMwLTUuMTYzIDMuMTU0LTcuOTc1IDcuNzYtNy45NzVoMy43OGMuNDg0IDAgLjg3Ni4zOTIuODc2Ljg3NnYzLjg4M2EuODc2Ljg3NiAwIDAgMS0uODc1Ljg3NmgtMi4zMmMtMi41MDUgMC0yLjk5IDEuMTkxLTIuOTkgMi45Mzh2My44NTJoNS41MDRjLjUyNSAwIC45MzIuNDU4Ljg3Ljk4bC0uNTQ2IDQuNjA0YS44NzYuODc2IDAgMCAxLS44Ny43NzNoLTQuOTM0bC0uMDI0IDE0LjI4Nmg4LjU3YTUuMzg3IDUuMzg3IDAgMCAwIDUuMzg3LTUuMzg3VjUuMzg3QTUuMzg3IDUuMzg3IDAgMCAwIDM0LjU5MiAweiIvPgo8L3N2Zz4K" alt=""/></a></li><li><a href="https://twitter.com/daytondotcom"><img src="data:image/svg+xml;base64,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" alt=""/></a></li></ul></li></ul></footer><div class="c-copyright"><div class="copyright">© <!-- -->2020<!-- --> <a href="/">Dayton.com<!-- -->.</a> All Rights Reserved. By using this website, you accept the terms of our<!-- --> <a href="https://www.daytondailynews.com/local/visitor-agreement/OHHOKFZZZZBJBBU7LY4IY7TW6Q/">Visitor Agreement</a> and<!-- --> <a href="https://www.daytondailynews.com/what-to-know/privacy-policy/EYDINSGNPZBZ5GXNWBKDGFNR5M/">Privacy Policy</a>, and understand your options regarding<!-- --> <a href="https://www.daytondailynews.com/what-to-know/privacy-policy/EYDINSGNPZBZ5GXNWBKDGFNR5M/">Ad Choices</a>. Learn about <a href="https://jobs.coxenterprises.com/?prefilters=none&amp;CloudSearchLocation=none&amp;CloudSearchValue=none/">Careers at Cox Enterprises</a>.</div></div></div><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/article/default.js?d=95" defer=""></script><script type="application/javascript">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</script><script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js"></script><script type="text/javascript" src="https://loader-cdn.azureedge.net/prod/ajc/loader.min.js"></script><script type="text/javascript">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</script><div id="fb-root"></div><script async="" defer="" crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v6.0"></script></body></html>