<!DOCTYPE html><html><head><link rel="apple-touch-icon" href="/pf/resources/images/favicon-apple-touch-icon.png?d=57"/><link rel="shortcut icon" href="/pf/resources/icons/favicons/Ohio/dayton-favicon.ico?d=57"/><link rel="canonical" href="https://www.dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="A new tenant, that has yet to be named, is coming to The Greene Towne Center in Beavercreek near Von Maur."/><meta name="twitter:image" content="https://www.dayton.com/resizer/_RQcfTyN_wdWhpPKexv7BmBpKjw=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/BUC5NJ2DWDC5ZCCDCNBSJOK5L4.jpg"/><meta name="twitter:site" content="@dayton"/><meta name="twitter:title" content="New tenant coming to The Greene in large space"/><meta name="twitter:url" content="/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/"/><meta property="og:image" content="https://www.dayton.com/resizer/_RQcfTyN_wdWhpPKexv7BmBpKjw=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/BUC5NJ2DWDC5ZCCDCNBSJOK5L4.jpg"/><meta property="og:image:height" content="630"/><meta property="og:image:width" content="1200"/><meta property="og:title" content="New tenant coming to The Greene in large space"/><meta property="og:type" content="article"/><meta property="og:url" content="/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/"/><meta property="og:description" content="A new tenant, that has yet to be named, is coming to The Greene Towne Center in Beavercreek near Von Maur."/><meta property="og:site_name" content="dayton"/><title>New tenant coming to The Greene in large space</title><meta name="thumbnail" content="https://www.dayton.com/resizer/_RQcfTyN_wdWhpPKexv7BmBpKjw=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/BUC5NJ2DWDC5ZCCDCNBSJOK5L4.jpg"/><meta name="language" content="English"/><meta property="article:opinion" content="false"/><meta name="story.meter" content="free"/><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","inLanguage":"en_US","mainEntityofPage":{"@type":"WebPage","@id":"https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/"},"publisher":{"@type":"Organization","name":"Dayton","logo":{"@type":"ImageObject","url":"https://cloudfront-us-east-1.images.arcpublishing.com/coxohio/YRHUB5MLSRHN3GFTFUEH36LH4M.png"}},"articleSection":"local","headline":"New tenant coming to The Greene in large space","datePublished":"2020-09-24T20:07:22.768Z","dateModified":"2020-09-24T20:07:22.768Z","author":{"@type":"Organization","name":"Bonnie Meibers"},"image":{"@type":"ImageObject","url":"https://cloudfront-us-east-1.images.arcpublishing.com/coxohio/BUC5NJ2DWDC5ZCCDCNBSJOK5L4.jpg"},"description":""}</script><link rel="amphtml" href="/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/?outputType=amp"/><link id="fusion-template-styles" rel="stylesheet" type="text/css" href="/pf/dist/components/combinations/default.css?d=57"/><script type="text/javascript">
        const initialDataObj = {
          "connextActive": "true",
          "pageData": {
            "pageName": "/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/",
            "pageURL": "https://www.dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/",
            "pageSiteSection": "/local",
            "pageMainSection": "/local",
            "pageCategory": "/what-to-know",
            "pageContentType": "Article",
            "pageTitle": "New tenant coming to The Greene in large space"
          },
          "siteData": {
            "siteID": "daytondotcom",
            "siteDomain": "dayton.com",
            "siteVersion": "responsive site",
            "siteFormat": "entertainment",
            "siteMetro": "oh: dayton",
            "siteMedium": "np",
            "siteType": "free",
            "siteCMS": "arc"
          },
          "contentData": {
            "contentTopics": "ddnhomepage,beavercreek,b2bnewsletter",
            "contentByline": "bonnie meibers",
            "contentOriginatingSite": "daytondotcom",
            "contentID": "46FSAZIGEVGXRDWK3AZRN7CR3M",
            "contentVendor": "",
            "contentPublishDate": "20200924041918",
            "blogName": "",
            "galleryName": "",
            "contentPaywallStatus": "free"
          }
        };
        // we do a check just in case dataLayer has already been created
        if (window.dataLayer) {
          dataLayer.push(initialDataObj);
        } else {
          dataLayer = [initialDataObj];
        }
      </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P72HT8T');</script><script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=57" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=57" defer=""></script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=57" defer=""></script><script type="text/javascript">window.ntvConfig = window.ntvConfig || {}; window.ntvConfig.keyValues = {"topics":"ddnhomepage,beavercreek,b2bnewsletter","uuid":"46FSAZIGEVGXRDWK3AZRN7CR3M"};</script><script type="text/javascript">let _prx = window._prx || []; _prx.push(['cfg.SetNoAutoStart']);</script><script type="text/javascript" src="//s.ntv.io/serve/load.js" async=""></script><script type="text/javascript">window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
      if (!document.getElementById(i)) {
        e.async = 1;
        e.src = u;
        e.id = i;
        f.parentNode.insertBefore(e, f);
      }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/cox-atlantajournal-constitution/loader.js',
    'tb_loader_script');
    if (window.performance && typeof window.performance.mark == 'function') {
      window.performance.mark('tbl_ic');
    }</script><link rel="stylesheet" href="/pf/resources/dist/dayton/css/style.css?d=57"/><link rel="icon" type="image/x-icon" href="/pf/resources/icons/favicons/Ohio/dayton-favicon.ico?d=57"/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:pages" content="13310147298"/>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-5b496c4e-462b-4130-86b9-790e6566db96","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="Q8952-D25UV-TUGGF-B5DRT-7NP9S",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"Q8952-D25UV-TUGGF-B5DRT-7NP9S",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubdipz2bsx3ndw5a-f-39853aa95-clientnsv4-s.akamaihd.net",i={"ak.v":"28","ak.cp":"1055649","ak.ai":parseInt("626554",10),"ak.ol":"0","ak.cr":7,"ak.ipv":4,"ak.proto":"h2","ak.rid":"2179ed2f","ak.r":35595,"ak.a2":e,"ak.m":"","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":52658,"ak.gh":"104.126.116.21","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"","ak.t":"1600986554","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==zD1PQSaaSHKm7eEUGbniN4kdUNyx4vd3ioR7tCDAEiNXF9moS9QjIC72qKc1jRj+TdcKXlY5xFtOVmLm1RV/2ljqwL6ZluxVUXfiETd5QezZADjOu1xnGB5uDZp+Qsh4YTavLBj8Vw2+HEU75g8ruX5fasGurWlhTONJcLSyGHlFY0boNhBr1fI4S/oklnTd7cKiElcVBdMkWRcjQzYpBq8+ajXIeIJyOL2z/sGP4bXt16WOZyf2HpLC4yKXaZJXeeJAkLvaQA5QDsDxAVIdO4eyOzuTNVuhW9CCRiMAJLHfvnxn3wYvaATuQX1I3VQ9t97wh2wYkB9C84qaHPI0BV6oowCJjNz8pDn58eKG8/9KmReJ+qc6h/4LoGvHEhWble2CuQtOVmFNmj7ll91HdvFz7pkcnNhGqT6NpCCfIPU=","ak.pv":"10","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src='https://www.googletagmanager.com/ns.html?id=GTM-P72HT8T' height='0' width='0' style='display:none;visibility:hidden'></iframe></noscript><div id="fusion-app"><div class="b-hidden"></div><div class="b-hidden"></div><div class="nav-breaking-news "><header class="c-nav"><div class="c-headerNav
        
        
        "><div class="b-flexRow b-flexCenter nav-logo
        "><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><div class="nav-mobile-logo "><a href="/"><img src="/pf/resources/logos/Dayton/logo-full.svg?d=57" class="logo dayton"/></a></div></div><div class="nav-wrapper "></div><nav class="
  
  
  "><div class="nav-menu-toggle"><div class="nav-close-button"></div></div><div class="nav-menu-header"><a href="/"><img src="/pf/resources/logos/Dayton/logo-mobile-hamburger.svg?d=57" class="nav-menu-logo dayton"/></a></div><ul class="nav-row"><li class="nav-mobile-footer"><div class="b-flexCenter b-flexRow"><div class="nav-social"><a href="https://www.facebook.com/daytondotcom" target="_blank" rel="noopener noreferrer"><img src="data:image/png;base64,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"/></a><a href="https://www.twitter.com/daytondotcom" target="_blank" rel="noopener noreferrer"><img src="data:image/png;base64,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"/></a></div></div><div class="nav-copyright b-flexRow b-flexCenter"><span style="padding-right:5px">© <!-- -->2020</span><a href="/">Dayton.com</a></div><div class="b-flexRow b-flexCenter nav-copyright-links"></div></li><li class="nav-weather-widget"></li><div class="nav-itemBottomBorder nav-sections"><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Know</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-know/">What to Know</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-3"><li class="flyout-item"><a href="/what-to-know/" target="_self">All What to Know</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/tornado-recovery/tNzEAjgwWVdRFgQIecomCM/" target="_self">Dayton Strong: Tornado Recovery</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/oregon-district-shooting/" target="_self">Oregon District Mass Shooting</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Do</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-do/">What to Do</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/what-to-do/" target="_self">All What to Do</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/events/" target="_self">Events</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/breweries-bars/" target="_self">Breweries &amp; Bars</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/parks-recreation/" target="_self">Parks &amp; Rec</a></li><li class="flyout-item"><a href="/travel/worth-the-drive/TeSpLNabWxMiGdukqnFH5L/" target="_self">Travel</a></li><li class="flyout-item"><a href="/marketing/haunted-houses/aU3vcAEUNtz5SaJM7vm6LJ/" target="_self">Haunted Houses</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Love</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-love/">What to Love</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-6"><li class="flyout-item"><a href="/what-to-love/" target="_self">All What to Love</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-bucket-list/" target="_self">Dayton Bucket List</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek/" target="_self">Daytonian of the Week</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-history/" target="_self">Dayton History</a></li><li class="flyout-item"><a href="/lifestyles/what-had-happened-was/5x2HBLiVbAUA2QAKCFdBhN/" target="_self">What Had Happened Was...</a></li><li class="flyout-item"><a href="/what-to-do/volunteer/volunteer-opportunities/" target="_self">Volunteer</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/best-of-dayton" target="_self">Best of Dayton</a></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/event-photo-galleries/" target="_self">Event Photos</a></li><li class="nav-items nav-separator"><span class="separatorBar"></span></li><li class="nav-items nav-itemText "><a href="https://myaccount.daytondailynews.com/dn/home" target="_self">Newsletters</a></li><li class="nav-search"><form class="search-form"><input type="text" name="value" value="" class="search-input"/><button type="submit" class="c-search-icon"><img class="search-icon" src="data:image/svg+xml;base64,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"/></button></form></li></div><li class="nav-weather weather-icon weather-12" title="Light rain"></li><li class="nav-itemText nav-weather weather-text"><a href="/weather/">66<!-- -->°</a></li><div class="nav-mobile-login"><li class="nav-login nav-items "><div data-mg2-action=""><img src="data:image/svg+xml;base64,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"/><div class="nav-itemText login-text is-profileAnon">Log in</div><div class="nav-itemText login-text is-profileAuthed">My Profile</div></div><div class="section is-profileAuthed "><div class="section-item"><a href="//myaccount.daytondailynews.com/dn/myprofile"><img src="data:image/svg+xml;base64,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"/><div class="nav-itemText login-text">My Profile</div></a></div><div class="subNav "><ul class="subNav-flyout"><li class="flyout-item"><a href="//myaccount.daytondailynews.com/dn/dashboard" target="_blank">My Account</a></li><li class="flyout-item"><a href="//myaccount.daytondailynews.com/dn/preference" target="_blank">Newsletters</a></li><li class="flyout-item"><a href="//events.dayton.com">Events</a></li><li class="flyout-item"><a href="/our-products/">Our Products</a></li><li class="flyout-item MG2activation"><a href="#" data-mg2-action="activation">Activate My Account</a></li></ul><a href="#" class="btn-logout nav-profileLogout" data-mg2-action="logout">Logout</a></div></div></li></div></ul></nav><div class="connext-subscribe  "></div><div class="stickyNav "><ul class="c-stickyNav-list dayton"><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><li class="stickyNav-item mobile-hidden"><a href="/"><img class="sticky-logo dayton" src="/pf/resources/logos/Dayton/logo-short.svg?d=57" alt="dayton logo"/></a></li><div class="stickyNav-social "><li class="stickyNav-item"><a href="https://www.facebook.com/share.php?u=https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/" class="sticky-nav-icon btn-facebook" target="__blank"></a></li><li class="stickyNav-item"><a href="https://twitter.com/intent/tweet?url=https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/&amp;text=New tenant coming to The Greene in large space" class="sticky-nav-icon btn-twitter" target="__blank"></a></li><ul class="c-stickyNav-list dropdown-stickyNav "><li class="stickyNav-item arrow-icon desktop-hidden"><a href="#" class="sticky-nav-icon btn-arrow-down" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.pinterest.com/pin/create/button/?url=https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/&amp;media=https://www.dayton.com/resizer/_RQcfTyN_wdWhpPKexv7BmBpKjw=/1200x630/cloudfront-us-east-1.images.arcpublishing.com/coxohio/BUC5NJ2DWDC5ZCCDCNBSJOK5L4.jpg&amp;description=New tenant coming to The Greene in large space" class="sticky-nav-icon btn-pinterest" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.reddit.com/submit?url=https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/&amp;title=New tenant coming to The Greene in large space" class="sticky-nav-icon btn-reddit" target="__blank"></a></li><li class="stickyNav-item"><a href="mailto:?Subject=New tenant coming to The Greene in large space&amp;body=https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/" class="sticky-nav-icon btn-mail" target="__blank"></a></li></ul></div></ul><div class="b-flexRow c-stickyLogin"><div class="sticky-logo-homepage dayton hidden"><a href="/"><img src="/pf/resources/logos/Dayton/logo-short.svg?d=57" class="dayton" alt="dayton logo"/></a></div><div class="stickyNav-homepage hidden"><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Know</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-know/">What to Know</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-3"><li class="flyout-item"><a href="/what-to-know/" target="_self">All What to Know</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/tornado-recovery/tNzEAjgwWVdRFgQIecomCM/" target="_self">Dayton Strong: Tornado Recovery</a></li><li class="flyout-item"><a href="https://www.daytondailynews.com/news/local/oregon-district-shooting/" target="_self">Oregon District Mass Shooting</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Do</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-do/">What to Do</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/what-to-do/" target="_self">All What to Do</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/events/" target="_self">Events</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/breweries-bars/" target="_self">Breweries &amp; Bars</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-do/parks-recreation/" target="_self">Parks &amp; Rec</a></li><li class="flyout-item"><a href="/travel/worth-the-drive/TeSpLNabWxMiGdukqnFH5L/" target="_self">Travel</a></li><li class="flyout-item"><a href="/marketing/haunted-houses/aU3vcAEUNtz5SaJM7vm6LJ/" target="_self">Haunted Houses</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>What to Love</a></div><div class="section "><div class="section-item"><a href="https://www.dayton.com/what-to-love/">What to Love</a></div><div class="subNav " style="width:nullpx"><ul class="subNav-flyout itemCount-6"><li class="flyout-item"><a href="/what-to-love/" target="_self">All What to Love</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-bucket-list/" target="_self">Dayton Bucket List</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek/" target="_self">Daytonian of the Week</a></li><li class="flyout-item"><a href="https://www.dayton.com/what-to-love/dayton-history/" target="_self">Dayton History</a></li><li class="flyout-item"><a href="/lifestyles/what-had-happened-was/5x2HBLiVbAUA2QAKCFdBhN/" target="_self">What Had Happened Was...</a></li><li class="flyout-item"><a href="/what-to-do/volunteer/volunteer-opportunities/" target="_self">Volunteer</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/best-of-dayton" target="_self">Best of Dayton</a></li><li class="nav-items nav-itemText "><a href="https://www.dayton.com/event-photo-galleries/" target="_self">Event Photos</a></li><li class="nav-items nav-separator"><span class="separatorBar"></span></li><li class="nav-items nav-itemText "><a href="https://myaccount.daytondailynews.com/dn/home" target="_self">Newsletters</a></li></div><li class="nav-login nav-items "><div data-mg2-action=""><img src="data:image/svg+xml;base64,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"/><div class="nav-itemText login-text is-profileAnon">Log in</div><div class="nav-itemText login-text is-profileAuthed">My Profile</div></div><div class="section is-profileAuthed "><div class="section-item"><a href="//myaccount.daytondailynews.com/dn/myprofile"><img src="data:image/svg+xml;base64,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"/><div class="nav-itemText login-text">My Profile</div></a></div><div class="subNav "><ul class="subNav-flyout"><li class="flyout-item"><a href="//myaccount.daytondailynews.com/dn/dashboard" target="_blank">My Account</a></li><li class="flyout-item"><a href="//myaccount.daytondailynews.com/dn/preference" target="_blank">Newsletters</a></li><li class="flyout-item"><a href="//events.dayton.com">Events</a></li><li class="flyout-item"><a href="/our-products/">Our Products</a></li><li class="flyout-item MG2activation"><a href="#" data-mg2-action="activation">Activate My Account</a></li></ul><a href="#" class="btn-logout nav-profileLogout" data-mg2-action="logout">Logout</a></div></div></li></div></div><div class="c-comments "><div class="close">X</div><div class="fb-comments" data-href="https://dayton.com/news/new-tenant-coming-to-the-greene-in-large-space/46FSAZIGEVGXRDWK3AZRN7CR3M/" data-width="100%" data-numposts="100"></div></div></div><div class="sticky-padding "></div></header></div><main class="c-articleContent"><header class="b-margin-bottom-d30-m20"><div class="c-header"><div class="article-headline-component b-margin-bottom-d30-m20 with-image"><div class="headline"><div class="headline-body"><h1 class="headline-text ">New tenant coming to The Greene in large space</h1></div></div><div class="c-image-component "><div class="image-component-image "><img src="" style="display:none" alt="The Greene Town Center in Beavercreek opened in 2006 and is now boasting more than 100 shops and restaurants in the mixed retail open shopping center. TY GREENLEES / STAFF" class=""/><img src="/pf/resources/logos/Dayton/placeholder.svg?d=57" style="width:100%"/><div class="c-caption " id="captionID-8372319" on="tap:captionID-8372319.toggleClass(class=&#x27;is-active&#x27;)" role="button" tabindex="0"><div class="photo-caption-btn"><div class="fill-line fill-line-long"></div><div class="fill-line"></div><div class="fill-line fill-line-long"></div><div class="fill-line"></div><div class="fill-line fill-line-long"></div></div><div class="photo-caption"><div class="photo-caption-text">The Greene Town Center in Beavercreek opened in 2006 and is now boasting more than 100 shops and restaurants in the mixed retail open shopping center. TY GREENLEES / STAFF</div><p class="photo-credit-text"></p></div></div></div><p class="photo-credit-text"></p></div></div></div><div style="display:flex;justify-content:center;flex-wrap:wrap" class="c-label-wrapper b-pageContainer b-margin-bottom-d15-m10"><a class="section-label section-label-link" href="/local">Local News</a><span class="article-timestamp"> | 2 hours ago</span></div><div class="b-flexRow b-flexCenter b-pageContainer"><div class="byline b-margin-bottom-d40-m20"><span>By <!-- -->Bonnie Meibers</span></div></div><div class="b-flexRow b-flexCenter b-margin-bottom-d15-m10 b-pageContainer"></div></header><article><div class="c-hp01-mp01"></div><div class="c-section
          full-width b-clear-both
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">A new tenant, that has yet to be named, is coming to The Greene Towne Center in Beavercreek near Von Maur.</p></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">The new tenant will take up the entire lower level of Building No. 3, according to a letter sent to other businesses in The Greene from Steve Willshaw, the general manager. This spot is where Gap, which is now closed, anchored one end and Flash Photography is on the other end.</p><p class="story-text b-margin-bottom-d40-m20">Flash Photography will relocate next to Torrid on Holly Drive over the next week, the letter said.</p></div></div><div class="story-nativo_placeholder--moap b-clear-both"></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">“We are very excited about this new tenant that will be occupying the space. The entire town center is going to benefit tremendously from their presence here,” Willshaw said in the letter.</p><p class="story-text b-margin-bottom-d40-m20">Renovations will begin on a total of 30,000 square feet in the building soon.</p></div></div><div class="c-section"><div class="story-interscroller__placeholder full-width c-clear-both c-contentElements"></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><section class="borders b-margin-bottom-d40-m20"><span class="prefix">Explore</span><a class="link" href="https://www.daytondailynews.com/news/local/defying-the-odds-brio-tuscan-grille-reopens-the-greene-for-carryout-delivery/dlk2YcIZMKyr2zHLtO6yNJ/" target="_self">Brio Tuscan Grille at The Greene to reopen dining room</a></section><p class="story-subscription__placeholder subscription-promo b-margin-bottom-d40-m20"></p><p class="story-text b-margin-bottom-d40-m20">The Beavercreek planning department said it had not received any construction permit requests for the space.</p><p class="story-text b-margin-bottom-d40-m20">“With a project of this magnitude and with deadlines to meet, there is going to be a lot of construction activity going on it and around the building over the next four months. The contractor is working with us on a schedule for all the various tasks they need to perform that fits in with the town center’s business model," the letter from The Greene reads.</p><p class="story-text b-margin-bottom-d40-m20">Willshaw would not give additional details on the new tenant.</p><p class="c-connext hyperlocal_promo b-margin-bottom-d40-m20"></p><p class="c-connext eos-msg__nolog-or-nosub b-margin-bottom-d40-m20"></p></div></div><div class="story-nativo_placeholder--boap "></div></article></main><footer class="c-footer b-clear-both"><div class="logo-row"><div class="col"><a href="/"><img class="footer-logo dayton" src="/pf/resources/logos/Dayton/logo-full.svg?d=57" alt="logo"/></a></div><div class="col"><a href="https://myaccount.daytondailynews.com/dn/preference/" class="newsletter-signup"><p>Sign up for our newsletters</p><img src="data:image/svg+xml;base64,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" alt=""/></a></div></div><ul class="menu-row"><li class="menu "><div class="menu-header">What to Know<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://www.dayton.com/what-to-know/" target="">Latest Headlines</a></li><li class="menu-body-links"><a href="https://membercenter.journal-news.com/newsletters" target="">Sign up for Newsletters</a></li><li class="menu-body-links"><a href="https://www.dayton.com/contact-us/" target="">Contact Us</a></li></ul></li><li class="menu "><div class="menu-header">What to Do<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://www.dayton.com/what-to-do/events" target="">Events</a></li><li class="menu-body-links"><a href="https://www.dayton.com/what-to-do/dining" target="">Restaurants</a></li></ul></li><li class="menu "><div class="menu-header">What to Love<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="/best-of-dayton" target="">Best of Dayton</a></li><li class="menu-body-links"><a href="https://www.dayton.com/what-to-love/daytonianoftheweek" target="">Daytonian of the Week</a></li></ul></li><li class="menu "><div class="menu-header">Event Calendar<img class="menu-arrow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNiIgaGVpZ2h0PSIxNSIgdmlld0JveD0iMCAwIDI2IDE1Ij4KICAgIDxwYXRoIGZpbGw9IiM5QjlCOUIiIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTEyLjA4NiAxLjEwNUwuMzA2IDEyLjg2NWEuNzAyLjcwMiAwIDAgMCAwIC45OTguNzA1LjcwNSAwIDAgMCAxIDBMMTIuNTg0IDIuNjA0bDExLjI3OCAxMS4yNTlhLjcxLjcxIDAgMSAwIDEuMjA5LS40OTYuNjg4LjY4OCAwIDAgMC0uMjEtLjQ5N0wxMy4wODEgMS4xMWEuNzA0LjcwNCAwIDAgMC0uOTk1LS4wMDV6Ii8+Cjwvc3ZnPg==" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://www.dayton.com/what-to-do/submit-events/" target="">Submit an Event</a></li><li class="menu-body-links"><a href="https://www.daytondailynews.com/local/visitor-agreement/OHHOKFZZZZBJBBU7LY4IY7TW6Q/" target="">Visitor Agreement</a></li></ul></li><li class="menu social-media"><span class="header-menu">Follow</span><ul class="social-media-icons"><li><a href="https://www.facebook.com/daytondotcom"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MCIgaGVpZ2h0PSI0MCIgdmlld0JveD0iMCAwIDQwIDQwIj4KICAgIDxwYXRoIGZpbGw9IiMyRTgxQjciIGZpbGwtcnVsZT0ibm9uemVybyIgZD0iTTM0LjU5MiAwSDUuMzg3QTUuMzg3IDUuMzg3IDAgMCAwIDAgNS4zODd2MjkuMjA1YTUuMzg3IDUuMzg3IDAgMCAwIDUuMzg3IDUuMzg3aDE0LjQwNGwuMDI0LTE0LjI4NmgtMy43MTFhLjg3Ni44NzYgMCAwIDEtLjg3Ni0uODczbC0uMDE4LTQuNjA1YS44NzYuODc2IDAgMCAxIC44NzYtLjg3OWgzLjcwNXYtNC40NWMwLTUuMTYzIDMuMTU0LTcuOTc1IDcuNzYtNy45NzVoMy43OGMuNDg0IDAgLjg3Ni4zOTIuODc2Ljg3NnYzLjg4M2EuODc2Ljg3NiAwIDAgMS0uODc1Ljg3NmgtMi4zMmMtMi41MDUgMC0yLjk5IDEuMTkxLTIuOTkgMi45Mzh2My44NTJoNS41MDRjLjUyNSAwIC45MzIuNDU4Ljg3Ljk4bC0uNTQ2IDQuNjA0YS44NzYuODc2IDAgMCAxLS44Ny43NzNoLTQuOTM0bC0uMDI0IDE0LjI4Nmg4LjU3YTUuMzg3IDUuMzg3IDAgMCAwIDUuMzg3LTUuMzg3VjUuMzg3QTUuMzg3IDUuMzg3IDAgMCAwIDM0LjU5MiAweiIvPgo8L3N2Zz4K" alt=""/></a></li><li><a href="https://twitter.com/daytondotcom"><img src="data:image/svg+xml;base64,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" alt=""/></a></li></ul></li></ul></footer><div class="c-copyright"><div class="copyright">© <!-- -->2020<!-- --> <a href="/">Dayton.com<!-- -->.</a> All Rights Reserved. By using this website, you accept the terms of our<!-- --> <a href="https://www.daytondailynews.com/local/visitor-agreement/OHHOKFZZZZBJBBU7LY4IY7TW6Q/">Visitor Agreement</a> and<!-- --> <a href="https://www.daytondailynews.com/what-to-know/privacy-policy/EYDINSGNPZBZ5GXNWBKDGFNR5M/">Privacy Policy</a>, and understand your options regarding<!-- --> <a href="https://www.dayton.com/privacy_policy/#ad-choices">Ad Choices</a>. Learn about <a href="https://jobs.coxenterprises.com/?prefilters=none&amp;CloudSearchLocation=none&amp;CloudSearchValue=none/">Careers at Cox Enterprises</a>.</div></div></div><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/article/default.js?d=57" defer=""></script><script type="application/javascript">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</script><script type="text/javascript"></script><script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js"></script><script type="text/javascript" src="https://loader-cdn.azureedge.net/prod/ajc/loader.min.js"></script><script type="text/javascript">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</script><div id="fb-root"></div><script async="" defer="" crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v6.0"></script></body></html>